Registry mis-match

General question about the package, problems, solutions
mjaskilka
Posts: 16
Joined: Mon Apr 30, 2012 2:23 pm

Registry mis-match

Postby mjaskilka » Fri May 25, 2012 3:29 pm

Hello,

I recently downloaded the package for the first time. The email package is v1.5. That part works great. Now, I want to install the subscription piece, but get an error using the package wizard: "Enabling of schema failed... Failed to read from registry: "software\rational software\clearquest packaged\emailnotification\1.4\DataPath". Name:"DataPath"...

Now, does this mean the subscription package is only compatible with v1.4 or is this a pointer not up-to-date? I don't have the 1.4 version installed. Also, On the original email package install, I tweaked the .pl file to place the registry entries in the same location as the existing entries, which is under "software\Wow6432Node\Rational Software\Clearquest packages\ since I'm working on a 64-bit machine.

So, what is the best way for me to fix this?

tnkx,

Mark

Pavel
Posts: 281
Joined: Fri Dec 12, 2008 12:19 am

Re: Registry mis-match

Postby Pavel » Fri May 25, 2012 3:43 pm

Hello,

you can either register EmailNotification 1.4, or update dependency information in tje "EmailSubscription\1.1\package.ini" file (replace "Dependency=EmailNotification 1.4" with Dependency=EmailNotification 1.5) and re-register EmailSubscription package.

Pavel

Pavel
Posts: 281
Joined: Fri Dec 12, 2008 12:19 am

Re: Registry mis-match

Postby Pavel » Mon May 28, 2012 8:26 am

I repackaged the distribution with corrected dependency. New downloads would not have this issue.

Thank you,
Pavel

mjaskilka
Posts: 16
Joined: Mon Apr 30, 2012 2:23 pm

Re: Registry mis-match

Postby mjaskilka » Tue May 29, 2012 6:25 pm

Thanks Pavel! That worked.

Mark


Return to “Email Notification Package Q&A”

Who is online

Users browsing this forum: No registered users and 1 guest

cron